UA-65274002-1 Jump to content
jiggity76

How to clean my Cutlass.

Recommended Posts

Working with a place out of Wisconsin, they seem very promising to repair the 91 International's digital cluster.  I sent them photo's of it and spoke with a tech on the phone and they seem very confident in doing the repair.  I hope to get it packaged up and shipped out to them this week.

Share this post


Link to post
Share on other sites

Just got some bad news from the repair shop.  They replaced some capacitors and it's getting amperage but they said the cluster is not fixable.  I'm going to have to replace it.  I've got some leads on some new NOS clusters, one thanks to MemphisMan and some others scattered across the U.S. and Canada.  Bummer.

Share this post


Link to post
Share on other sites
1 hour ago, rich_e777 said:

Maybe worth a second opinion? I havent talked myself into walking away from my 1994 CS project yet but if I do I`ll sell you my UB3.

I talked to a local GM dealer and they gave me a contact of a place in the Chicago area.  The GM service department sends off their customer's clusters to this facility and he said if they can't fix it, no one can.  I'm going to give them a try.  I called them tonite and talked to one of their techs, he said he's pretty confident he can fix it so that's my next plan of attack.  I have a couple of good working UB3's but they're non HUD clusters and I really want to have the original HUD cluster working or find a NOS one to keep the car original as I can.  Thank you for the offer though Rich, very generous of you!

Share this post


Link to post
Share on other sites

I keep forgetting they had an even more rare version just for the HUD. If its the same people that do the Vette clusters then I think its in good hands, that`d be the only place I`d send one to.

Share this post


Link to post
Share on other sites

So the repair place in Chicago got ahold of me today, they said they can't repair it.  They referred me to a place in Detroit, MI, a place called Specmo I think.  I called them and gave them my part # and they said YES, we can repair that.  So I'm going to send it to them next week and hope for the best.  I'm getting worried about it.  I checked with a place in Canada that supposedly had an NOS one but they said nope, it was sold awhile ago.  I'm also checking with a lead from MemphisMan, an NOS one listed on Ebay, I'll check with them next week to see if they actually have one. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×