UA-65274002-1 Jump to content
1987 GMC Jimmy

Electrical Issues

Recommended Posts

Got some help already from @ManicMechanic, but I wanted to keep the discussion going on my issues. My new-to-me car has been sitting for about 15 (+/- a year) years. A lot, and I mean a lot, works in it that I’ve been able to check. The only things that aren’t are the turn signals, horns, and instrument clusters. I was just informed on the location of the turn flasher so I’ll replace it next chance I get. My horn relay clicks, and the fuse is good, but there’s no sound. If they’re like the old school horns I’ve played with, I can test them. Where are they located, though? I’ve searched, admittedly not too hard, but I haven’t seen them yet. Finally, my cluster is completely dead minus the backlighting that comes on when switching on the lights. It’s the base style cluster, and I do get a self-test of the warning lights and SES light. Locally, the two Cutlasses in the junkyard have the identical cluster (a ‘ 90) and then a traditional cluster in an SL coupe (‘93). I’ll have to check around to see if I can find one or two more of these cars. The full digital cluster would be cool, but I have to be honest, I’m not too thrilled about having to do a repin for that guy. Let me know what you guys think!

Share this post


Link to post
Share on other sites

That’d be good. My brother’s going to PAP this weekend (hopefully) so maybe I can get him to pull me that cluster and then the horns if I can tell him exactly where to look. Mine are all on the core support, but I didn’t know if this was different. This car is somewhat of a departure for me but luckily still a good bit of familiar territory. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×