Jump to content

2004 Grand Prix, wont start, has no ignition power inside the car


AL
 Share

Recommended Posts

Just bought this 04 GP and the guy I bought it from drove it to the store and when he came out, the car wouldnt start. His battery was original and tested bad, so we dropped a new battery in and it still wouldnt start. I have no dash lights with the exception of the engine light, no DLC ignition voltage and no ignition power to the DIC. The lights work fine, and I can check the clock on the radio, but it wont actually turn on... I have already replaced the ignition relays and the ignition switch. Still same problem... It also seems like there is a massive battery drain issue, the battery charger overheated trying to charge it and it killed my jumpbox, and now the 1 week old battery has 7 volts... Tested all fuses with the test light, and none are blown... I am lost at this point

Link to comment
Share on other sites

  • 2 weeks later...

All of the bcm grounds and positive wires are good, just tested the wires for the data information, the radio wires all tested good, what the heck could be causing this? Every pass key issue I've seen has had the dash lights come on, I'm totally lost

Link to comment
Share on other sites

Have you checked all of the battery cable connections? Specifically at the under hood fuse boxes? I've had this happen before on my old Regal, turned out to be a loose connection at the auxiliary positive terminal on one of the fuseboxes.

 

What I ended up doing was run another cable from the battery to said terminal, as the original cable couldn't carry the current. It would heat up the connection and loosen the bolt, causing the engine and half of the accessories to die. IIRC, the fuel pump relay was on the opposite fusebox and the fuel pump would activate with the ignition.

 

Just my 2 cents...

Link to comment
Share on other sites

We replaced battery cables and went over fuses a million times, we ended up stumbling across a forum thread that mentioned moisture getting on the harness under the passenger seat, so we took the seat out and lifted up the carpet to check the harness and saw that the airbag module looked horrible, had so much corrosion on it that it had me concerned. We unplugged the module and the car fired up. Basically the air bag module was shorting out the can bus system and everything on the can bus was not working. Finally glad to see this car run.

Link to comment
Share on other sites

Holy shitballs!

 

You know, now that I think about it, my Tahoe was acting up a couple of years ago where it'd die for no reason, or would crank but not fire. I traced it to the TCCM under the dash. Unplugged it and the truck ran normally. I pulled the module apart and the circuit board inside was corroded to hell. Goes to show ya one seemingly insignificant module can stop you dead in your tracks...

Link to comment
Share on other sites

  • 5 years later...

AL

i just bought a 05 pontiac grand prix and the identical thing happened to me i sure hope its something simple. i had to have my Pontiac towed when it wouldnt start. the tow truck driver grabbed wheel to put it on flat bed and the steeing shaft snapped the wheel was free spinning. so im glad the ignition messed up or the steering for surely would have broke on me on way home. they want $300 to even look at my car ontop of $110 tow bill i drove this car for 2 1/2 days and everybody has a different awnser starter. i said no i dont know much but i know the car would do something when i turn key id have dashlights and a radio not just fuel pump and lights. i also have a clicking relay on passenger side fuse box i replaced it but also clicks.idk i hope that your article helps me out before i change ignition switch or pcm and other electrical related problems which i believe it to be. 

Link to comment
Share on other sites

  • 6 months later...

I have the same issue my pontiac grand prix wont start. It's got a new battery, alternator, starter, and ignition switch. My dash lights up and windows work but she wont start for nothing. Wondering if anybody had any ideas.

Edited by The dude
Link to comment
Share on other sites

I have the same issue my pontiac grand prix wont start. It's got a new battery, alternator, starter, and ignition switch. My dash lights up and windows work but she wont start for nothing. Wondering if anybody had any ideas.

Check all your connections are clean and tight.
Link to comment
Share on other sites

7 hours ago, The dude said:

I have the same issue my pontiac grand prix wont start. It's got a new battery, alternator, starter, and ignition switch. My dash lights up and windows work but she wont start for nothing. Wondering if anybody had any ideas.

Won't START, or won't CRANK?  Big difference.

Link to comment
Share on other sites

  • 3 months later...
  • 1 month later...

Hello my 2005 Pontiac Grand Prix won’t crank. Changed battery ends check all fuses and battery all good. Everything in dash works just no crank. I took the starter and crank fuses out under hood and took jumper and it’ll crank that way

Link to comment
Share on other sites

  • 2 years later...

I have an 07 grand prix gt that will not crank I put the key in the ignition and turn to accessory and all my dash lights come on, and the moment I turn the key to crank the motor it kills everything ..it just shuts it all off

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...