UA-65274002-1 Jump to content
sampuppy1

00 Regal GS random stalling??????

Recommended Posts

Anyone who has seen my build knows that this damn $60 car has been the bane of my existence since I bought it. After finishing the fuel lines this fall I started it and let it idle for awhile and at some point it quit. I figured air in the lines and it hasn't done anything since.

 

I've notice it has sporatic variations in idle at random times. While coasting or after coming to a stop, the idle will rise and fall like I'm revving it a little. Today it has decided to drop so low it stalls......every time I coast to a stop.

 

Anyone have an idea as to where I should start??

 

Sent from my XT1635-01

 

Tyler/T-Unit

Share this post


Link to post
Share on other sites

If the check engine light is on start by reading the codes. If "feathering" the gas helps clean the IACV, if cleaning the IACV helps replace the IACV. You really should check the fuel pressure and since the fuel lines were bad perhaps think about having the injectors cleaned / replaced and flush the fuel rail.

Share this post


Link to post
Share on other sites

If the check engine light is on start by reading the codes. If "feathering" the gas helps clean the IACV, if cleaning the IACV helps replace the IACV. You really should check the fuel pressure and since the fuel lines were bad perhaps think about having the injectors cleaned / replaced and flush the fuel rail.

The light has been on for EGR valve. Fuel lines weren't that bad. The quick connect at the filter broke. I just replaced the lines and the rails as a precautionary measure.

 

It only does this when it's cold. After it got to temp it coasts like it should. This could be a tcc issue as it should be keeping rpms up when coasting in line with the speed of the car and the corresponding gear. It has been a little lazy in locking the converter when cold too so that very well could be playing a part in this...... I'm getting really tired of this dang thing. I may just buy a nicer one and start over and keep this for parts or part it out.

 

Sent from my XT1635-01

 

Tyler/T-Unit

Share this post


Link to post
Share on other sites

Dude, the EGR could be stuck open. And at idle let's think about how bad it would suck if you were calmy going about your business and someone was forcing your ass gas down your throat. Either replace the EGR or put a couple "no hole" gaskets under it. The code should be dealt with though, always fix what you know is broke before you look for other causes.

Share this post


Link to post
Share on other sites

Went through something similar with my 00 GPGT.  It would do it at a cold start.  The idle would flux so bad it would almost stall and then rev itself back up and do it over and over unless I kept my foot on it until it warmed up a bit.  Would also do it if I jumped in and drove it right away.  I replaced the EGR valve/gasket on it and all is well.

Share this post


Link to post
Share on other sites

Looks like I may have to mess with that then. It needed cleaned I do know that. And it very well could be stuck open. I'll have to get in there. Fixing what I know is broke.......Jesus. That's a long ass list. It needs a full exhaust system. Has a nasty leak somewhere by the down pipe. That could be causing it too. Upstream o2 getting false readings, EGR could be messed up. I really need a scanner.

 

Sent from my XT1635-01

 

Tyler/T-Unit

Share this post


Link to post
Share on other sites

If you have any kind of smart phone there's a million ELM interfaces for under $10 out there. Also Harbor freight has a new line of scan tools that look really nice, body codes and stuff. You could get into something like that under $200. A cheap $30 harbor freight one gets the job done for drivetrain though. I'd spend my money on a GOOD o2 and a cheap scan tool. EGR valves are plentiful at the wrecking yard.

Share this post


Link to post
Share on other sites

Got a solution. I'm gonna pull the EGR. I've got some diamond plate aluminum laying around. Got some copper gasket maker and I'll trace, cut and drill my own block off plate. Or I've got some.sheet stock laying around I could make my own no hole gasket for. Wouldn't get rid of my code, but it'll solve the stall and sporadic idle issue.

 

Sent from my XT1635-01

 

Tyler/T-Unit

Share this post


Link to post
Share on other sites

I used some hi temp RTV, and cut a piece of aluminum flashing in the shape of the EGR valve pedestal. It's blocked off and sealed now. I let it sit overnight and all day today and I'll drive it to work tomorrow.

 

Sent from my XT1635-01

 

Tyler/T-Unit

Share this post


Link to post
Share on other sites

Block off is a negative. Still surging and stalling. Less surging now though. Only when coasting and after letting off the throttle quickly. Slow let off and the RPMs stay up. Sharp let off results in 500-750rpm idle while coasting or a little surge and dip until it stalls. Also decided to stumble pretty bad sitting at a stop light tonight. Had to pedal it to keep it running and it stumbled a bit before it would rev up. Once I got rolling it was smooth. I stood on it and it wound right out to redline and it was fine after.

 

Might have to check into those crank sensor wires. The GP did something similar to me when they were rubbing on the serpentine belt. It would just die anywhere though. Full throttle highway pulls and it would just shut off, idling it would cut off and you'd never notice til you tried to take off. Tach would just drop out and that's how you knew it was gonna stall.

 

This is a little different but it wouldn't hurt to check the wires. I'll have to see about finding a scanner. I can't sell this fucker if it dies on a test drive.

 

Sent from my XT1635-01

 

Tyler/T-Unit

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...