UA-65274002-1 Jump to content
Heartbeat1991

Dan's TGP Take 4

Recommended Posts

Heartbeat1991

I bought my 4th TGP this weekend.  1989 with sunroof and leather.  47k on it.  This will likely be my last one for a while.  I plan to do an extensive restoration on this one, as it needs paint and general cleanup.  Most of these photos were from the listing.  The last couple I took when I started cleaning it up.

post-7331-0-66581800-1473084004_thumb.png

post-7331-0-09032300-1473084022_thumb.png

post-7331-0-94875000-1473084040_thumb.png

post-7331-0-28615200-1473084058_thumb.png

post-7331-0-17952800-1473084074_thumb.png

post-7331-0-25686800-1473084103_thumb.png

post-7331-0-65489100-1473084129_thumb.png

post-7331-0-13348000-1473084208_thumb.png

post-7331-0-74286100-1473084222_thumb.jpg

post-7331-0-61458000-1473084237_thumb.jpg

post-7331-0-27681900-1473084252_thumb.jpg

post-7331-0-48225100-1473084264_thumb.jpg

Share this post


Link to post
Share on other sites
Imp558

Congratulations, that looks really nice already.

Must have been in storage for a while, carphone and all.

Edited by Imp558

Share this post


Link to post
Share on other sites
Heartbeat1991

Got it running today.  The fuel pump was no good.  The fuel was way past no good, and for whatever reason, the injectors weren't working.  Took them out, cleaned them, ohm checked them and put them back in.  Now it runs pretty darn good.

post-7331-0-17369900-1473193652_thumb.jpg

Share this post


Link to post
Share on other sites
Luke94vert

Very nice pair there. Can't believe it still has a carphone in it. I haven't seen one of those in years. Can't wait to see the build of this one.

Share this post


Link to post
Share on other sites
Heartbeat1991

Really nice find!  Your lucky to have two beautiful GP Turbo's.  How do you clean the injectors?  Want to do that to my Cutlass.

There's no way to properly clean them at home.  You'd have to send them out to be cleaned.  I cleaned the outside.  I tried to start it the other day.  There are still problems.  I assume that it was a coincidence that it ran last time.  It seems there is a short somewhere in the fuel relay/fuse area.  I am working on that now.

Share this post


Link to post
Share on other sites
Heartbeat1991

I'm late to the thread, but this looks like a keeper

That's always the plan, until a better one comes along.  :-)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...