UA-65274002-1 Jump to content

vertgirl

Members
  • Content Count

    3
  • Donations

    $0.00 
  • Joined

  • Last visited

  1. OK, need help. I need to lay this out and get feedback as proof both of these garages are idiots, so here it goes, the complete story. 94 3.4. May 2013, broke serpentine belt, towed to garage. Replaced water pump, thermostat, belt, pulleys. Was told I had head gasket problems. Was leaking coolant somewhere when I picked up my car. Drove car to another garage, asked for pressure test to confirm. I was told there was a broken inlet valve on the bottom of the radiator, no way a pressure test could have been done on it to get to I had a bad head gasket. Took back to first garage, demanded they put radiator in my car, they did, no further leaks, no overeating problems, nothing. Drove all summer 2013 in 100+ heat with a/c going most days, top up or down. No problems of any kind. Parked it end of October for the winter. February, needed to use it to go pick up a dining room table with my trailer (it's got a factory installed trailer hitch), warmed it up, turned on the heat, blew nothing but cold air, froze my butt off for the 8 mile round trip. Parked it again for the rest of the winter. Saved up the money to get the "supposedly" blown head gaskets and decided to go ahead and have timing belt replaced at same time since it had been about 50K miles since being replaced, took it back to the garage that did the initial work with the water pump, radiator, etc., on August 31st. After 4 weeks and a lot of delays, got my car back on September 29. All seemed well. Drove for exactly 2 weeks. Went out one Monday morning to start it to go visit my brother in the hospital, it died. Tried again, it died. Got out to raise hood, oil all over my garage floor. Called garage to come get it, told them it looked like they might not have put my oil filter on tight or something, they towed it back to their garage. Called me the next day and said the oil sending unit was leaking, and oh by the way, you have a water leak. apparently they had let me leave the garage the first time, with a bad hose and didn't bother to replace it or even tell me about. After another 2 weeks, they were going to bring my car to my home since I had no way to come get it. So, manager was driving it to me, got about a mile from the store, overheated. towed it back to their garage. After another 7-10 of trying to figure out what was wrong, asked me if they could have it towed to another garage to get "correctly" diagnosed. A couple of days later, I get a phone call stating that the 2nd garage determined my heads had cracks in them and apparently the machine shop either missed it or something, so they were going to buy new heads for my car at their expense and fix it. Another week goes by. Winter is here, I have no ride, so they rent me a car to drive saying my car would be ready in a few days. Another week goes by. The 2nd shop is now telling them, they apparently repaired my heads, after I was told I was getting new ones, and now the block has pin holes in it, it's had them for over 2 years, and it's all "my fault" and the first garage isn't responsible for fixing my car as now my "piece of junk" car (their words) needs a whole new engine at a cost of over $6000. Next thing I know, my car is sitting in their parking lot torn down, they won't put it back together as "they won't be held responsible for it" and my rental car is yanked from me. So I am back on foot, no car, and their claims department is trying to say that for 2 years, my car has had pin holes in the block, can't be repaired, and they aren't going to do anything about it. Called today to find out when someone is going to put my car back together, waiting to hear that now. So, I need some professional opinions. Here is what I think. First garage that told me I needed head gaskets, replaced gaskets, let my car leave with a bad water hose, sent car to garage they have a "relationship" with (they send business back and forth), who are telling them I have been knowing driving my car for 2 years with a bad block, which is a lie. They repaired my heads apparently, put my car back together, guess what, still got hot I guess, so now instead of them standing behind that they told the first garage, the heads had cracks, now it's the engine block has pin holes and they aren't touching it again. Thoughts? And I guess I am going to have to sue them to get something done.
  2. any parts left for sale? would like an updated list, interested in a few things, thanks
×
×
  • Create New...