UA-65274002-1

Jump to content


Photo
- - - - -

How to clean my Cutlass.


  • Please log in to reply
59 replies to this topic

#41 jiggity76

jiggity76

    Advanced Member

  • Members
  • PipPipPip
  • 734 posts

Posted 13 September 2017 - 12:50 AM

We just went through that a couple months ago with someone else. That's the "Fuel Pump Prime" wire. If you power it you will hear the pump turn on. You don't need it.

Ok, so it's just a dummy wire then?  I'll just put it off to the side and maybe zip tie it to the other wire bundle.  Thank you.



#42 Imp558

Imp558

    Proud TransCelestialsexual

  • Contributing Member
  • 3,479 posts
  • LocationErie PA.

Posted 13 September 2017 - 12:59 AM

no it was intended as a means to test the fuel pump. but the fuel pump relay also has a place where you can power it and at the same time test the power to the relay so nobody actually uses the fuel pump prime wire

Banner.jpg

 

"If everything seems under control, you're not going fast enough"  - Mario Andretti

 

1996 Regal L67/4T65E-HD swapped

1980 Dodge Sno-Commander

1984 Dodge Prospector

1968 Empi Imp on '67 Pan


#43 jiggity76

jiggity76

    Advanced Member

  • Members
  • PipPipPip
  • 734 posts

Posted 13 September 2017 - 01:07 AM

no it was intended as a means to test the fuel pump. but the fuel pump relay also has a place where you can power it and at the same time test the power to the relay so nobody actually uses the fuel pump prime wire

Cool, I didn't know that they built that into the cars.  Like I said, I'll just zip tie it out of the way.  Do you have any ideas on the cluster?  Should I just change it out with the spare that I have and see if it works?  Can these clusters be rebuilt?  What about a bad fuse?

 

I have a buddy coming over this Saturday to help me with the DIS by the way.  I'll let everyone know how it goes.  I printed off all the info for the DIS upgrade to help us out.



#44 Imp558

Imp558

    Proud TransCelestialsexual

  • Contributing Member
  • 3,479 posts
  • LocationErie PA.

Posted 13 September 2017 - 01:12 AM

Saar is our local digi-dash guru.

Banner.jpg

 

"If everything seems under control, you're not going fast enough"  - Mario Andretti

 

1996 Regal L67/4T65E-HD swapped

1980 Dodge Sno-Commander

1984 Dodge Prospector

1968 Empi Imp on '67 Pan


#45 jiggity76

jiggity76

    Advanced Member

  • Members
  • PipPipPip
  • 734 posts

Posted 13 September 2017 - 01:17 AM

Saar is our local digi-dash guru.

Ok, I might give him a shout.



#46 Psych0matt

Psych0matt

    (╯°□°)╯

  • Members
  • PipPipPipPipPip
  • 13,169 posts

Posted 13 September 2017 - 01:33 AM

Thanks! I still watch your YouTube video every once in awhile. Did you add the DIS to yours or was that factory. Manic said that DIS was extremely rare for 91's. I like that your speedo shows up on the cluster since HUD cars were not suppose to do that. How hard was it to do that? Want to maybe do that to mine.

the dis, hud, and ub3 cluster were all added by me, and they were all pretty easy.

'92 5 speed GTP - Mod list _____ '06 Grand Prix SE - Daily Driver

G1OY81M.png


#47 jiggity76

jiggity76

    Advanced Member

  • Members
  • PipPipPip
  • 734 posts

Posted 13 September 2017 - 01:37 AM

the dis, hud, and ub3 cluster were all added by me, and they were all pretty easy.

When the time comes, I would like to pick your brain if you don't mind.  Everyone says it's strange that my car is not pre wired for the DIS even though it's a factory HUD and UB3 cluster car.



#48 Psych0matt

Psych0matt

    (╯°□°)╯

  • Members
  • PipPipPipPipPip
  • 13,169 posts

Posted 13 September 2017 - 01:54 AM

Iirc all I had to do was wire up two wires for power and a single splice into the aldl port

'92 5 speed GTP - Mod list _____ '06 Grand Prix SE - Daily Driver

G1OY81M.png


#49 jiggity76

jiggity76

    Advanced Member

  • Members
  • PipPipPip
  • 734 posts

Posted 13 September 2017 - 02:19 AM

Iirc all I had to do was wire up two wires for power and a single splice into the aldl port

Thanks!  Good lord I love your GTP coupe!


  • Psych0matt likes this

#50 Imp558

Imp558

    Proud TransCelestialsexual

  • Contributing Member
  • 3,479 posts
  • LocationErie PA.

Posted 14 September 2017 - 12:02 AM

Thanks! Good lord I love your GTP coupe!

Always been my favorite on the forum
  • Psych0matt likes this

Banner.jpg

 

"If everything seems under control, you're not going fast enough"  - Mario Andretti

 

1996 Regal L67/4T65E-HD swapped

1980 Dodge Sno-Commander

1984 Dodge Prospector

1968 Empi Imp on '67 Pan


#51 jiggity76

jiggity76

    Advanced Member

  • Members
  • PipPipPip
  • 734 posts

Posted 14 September 2017 - 01:04 AM

I love the stance, looks wicked.  I zip tied the connector and wire to the other bundle so it's nice and tidy by the way.



#52 jiggity76

jiggity76

    Advanced Member

  • Members
  • PipPipPip
  • 734 posts

Posted 14 September 2017 - 03:23 AM

Sunroof question - Now that I know my sunroof works, what's the best way to keep it moving smoothly?  Do you guys recommend cleaning it and then lubing it up with a good product like some sort of grease or spray?  Also, I noticed that the sunshade moves with the glass but when I try to move it when the glass is closed, it's stuck.  Can't slide it back to when the glass is forward and closed.



#53 jiggity76

jiggity76

    Advanced Member

  • Members
  • PipPipPip
  • 734 posts

Posted 16 September 2017 - 11:16 PM

Saar is our local digi-dash guru.

I got ahold of Saar and waiting for his response.  Switched out the cluster today with a good spare and still no lighty uppy.  Just shows exactly what the original cluster showed.  Do you guys have any suggestions while I wait to hear back from Saar?

 

KID6ma.jpg



#54 jiggity76

jiggity76

    Advanced Member

  • Members
  • PipPipPip
  • 734 posts

Posted 17 September 2017 - 01:24 AM

Is there a main computer or something that sends info to UB3 clusters?



#55 jiggity76

jiggity76

    Advanced Member

  • Members
  • PipPipPip
  • 734 posts

Posted 17 September 2017 - 06:13 PM

Alright, I'm a moron.  So it ended up just being a fuse.  Sorry to bother everyone about this.  Here it is all lit up showing 152,000 miles, more than I thought it had.  DIS is in but not hooked up, still working on it but wanted to see what it would look like.

 

OuwQCV.jpgDIp7fl.jpg


  • Imp558 likes this

#56 jiggity76

jiggity76

    Advanced Member

  • Members
  • PipPipPip
  • 734 posts

Posted 22 September 2017 - 02:36 AM

Sunroof question - Now that I know my sunroof works, what's the best way to keep it moving smoothly?  Do you guys recommend cleaning it and then lubing it up with a good product like some sort of grease or spray?  Also, I noticed that the sunshade moves with the glass but when I try to move it when the glass is closed, it's stuck.  Can't slide it back to when the glass is forward and closed.

Still can't get the sunshade to slide back, it pops up and gets crooked in front and still won't slide back.  I've tried pushing up and pulling down but no go.  It moves with the glass ok but can't get it to move independently of the glass.  I thought about pulling the glass from the outside to get access to the shade track but I think the only way to do that is to move the shade back.  Any ideas anyone?



#57 jiggity76

jiggity76

    Advanced Member

  • Members
  • PipPipPip
  • 734 posts

Posted 26 September 2017 - 01:10 AM

Well I'm back to square one on the dash cluster.  Fuse is NOT blown and my dash is not coming on again.  I've consulted Robertlsaar again, waiting to hear back.  I'm mad at my Cutlass right now!



#58 jiggity76

jiggity76

    Advanced Member

  • Members
  • PipPipPip
  • 734 posts

Posted 30 September 2017 - 12:54 AM

You'll need a DOHC dipstick, the 91-95 make use of a *T* handle, the 96-97 make use of a *pull-ring*

Alright, finally got the correct dipstick for the 91 International LQ1.  I found out that a dipstick from 91-92 will work but in 93 they changed to a yellow T handle one and it WILL NOT fit over the dipstick tube.  I drove three hours to get this one which sucked but also kinda fun!  Here it is!

 

sWOL0p.jpg

 

I got it off of a 92 GP SE LQ1.  I posted pics and some other cars in the junkyard thread never ending section.

 

I called my local GM dealer and he could not find any NOS ones anywhere.  Couldn't find one on Ebay.  Salvage yards who had the one I needed were too far away and wouldn't ship or I had to buy the whole freaking motor to get it.  I had to drive to get this one like I said because they are a Pick N Pull and won't ship, you gotta come down and pull it yourself!  Oh well, I had fun!



#59 jiggity76

jiggity76

    Advanced Member

  • Members
  • PipPipPip
  • 734 posts

Posted 05 October 2017 - 01:02 AM

Sunroof question - Now that I know my sunroof works, what's the best way to keep it moving smoothly?  Do you guys recommend cleaning it and then lubing it up with a good product like some sort of grease or spray?  Also, I noticed that the sunshade moves with the glass but when I try to move it when the glass is closed, it's stuck.  Can't slide it back to when the glass is forward and closed.

 

Got the shade to slide back but I had to vent the glass and push up from inside to get it to slide back.  It keeps getting hung up somewhere.  Found this black piece just laying between the glass and shade, obviously broken and don't know exactly where it goes.  Maybe it's causing the stuck shade problem?  It has a broken tab on one end and the other end has the tab barely hanging on and squished.  Anyone know what I should do?  At lease the shade is back now but I want it to slide like it should.  Do 88-97 model year cars all use the same sunroof components/parts?  Can I use parts from a Buick Regal or GP?

 

TZMi52.jpgCjwJe0.jpgptcdIS.jpgBbVnGN.jpgja2mr2.jpg



#60 jiggity76

jiggity76

    Advanced Member

  • Members
  • PipPipPip
  • 734 posts

Posted 06 October 2017 - 12:32 AM

Might need some moonroof parts.  Do these cars share the same components/parts throughout the years or are some years different from others.  Can I use parts from a GP or Regal?






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users