Results 1 to 8 of 8
  1. #1

    Hard downshift, rough acceleration

    DAMN AUTO CARS. Anyhow, here's my problem. Ever since I got the car back together it's been running funny when cold, jerking (violently) from 2-1 d/s. When it warms up it runs a little better, but the shift problem stays. I put a set of injectors in it, and it's acting like it has a vacuum leak. I just went over the whole vacuum system (except for the res., which I can't get to now) and I have no leaks. One thing that started yesterday (which really sux) when ever I go under heavy boost (9-10 psi) my vac. hose to the booster pops off :shock: :x ChisA (I think) or whomever has done a vac. swap, how did you keep the booster hose on?? I never had problems until yesterday. A few weeks ago I had to drive to work w/o ANY vacuum lines hooked up in the Cutty, so I know how it feels to drive w/ no vac. on the MAP sensor, or the fuel reg. That is EXACTLY what the driveability problem feels like. You have to stab the pedal to get it to go or it'll bog down. Here's the odd thing, when the vac. line pops off the booster, I DON'T GET A SES LIGHT. :?: :?: My light lights up upon test w/ the KO/EO. So why no SES light? As I said, when it warms up the problem all but disappears, but it's still there, ever so slightly. But WHY does it go away, what vacuum leak do I have that goes away w/ engine temp.? I thought manifold, but I checked my bolts, all tight, and I'm just lost altogether. I did get to race and beat a I6 Wrangler though. I'm only getting 18 MPG, ~~~~, If I can't at least get it upto 20, I'm gonna have to go back to the Gutless, which I don't wanna do when it's warm out, and I can peel that sunroof back. 8) Many thanks for whatever help I can get.
    Sonic Yellow Snow Cone<br />My WRX pics<br />My Mods

  2. #2

    Hard downshift, rough acceleration

    Sonic Yellow Snow Cone<br />My WRX pics<br />My Mods

  3. #3

    Hard downshift, rough acceleration

    18mpg!!! I wish either of our TGP's got 18mpg. I usually average right around 16.5 in my STE and the 2 door averages right around 17mpg. Unless you are talking about peak mpg not average, thats not something to be complaining about. Yeah, its not good by todays car standards, and wasn't really then either, but it doesn't get much better than that.

    Shawn
    99 Grand Prix GT 242,800+ miles<br />9.75:1 L36|K&amp;N|No Cat/Ubend/res|160 tstat|UD ALT|Shift Kit|Powertuner|Ported M90/LIM/TB/Heads|XPZ|Stg 2 IC|Pacesetters|ElecWP|AlumCradle|4340 IS|2.93 15/16&quot; Chain|2750 stall|2.55&quot;. <br />379.9whp on 93 octane, 11.9912 @ 112.99 w/1.729 60&#39;<br />Gen V/N* TB/3.69s since ET.<br />03 CBR 600RR Stock.&nbsp; 11.38 @ 123.64

  4. #4

    Hard downshift, rough acceleration

    Hell yes it does, Sunshine gets (yes, I'm talking about average) around 16-17 CITY!!! It gets 23+ highway. I know the extra gear helps, but I ONLY drove on the highway (40 miles a day) My Cutty gets about 21 mpg highway, and I can use 87 octane in it. I actually get better mileage w/ lower grade gas. I filled the TGP up today @ 1.99/gal. FUCK A BUNCH OF THAT!!! My last tank ended w/ a 16.3 mpg average. As soon as I got home, I drove the Cutty to Wal-Mart to make sure it was still running good. (Haven't driven it in a week or 2) I have noticed a few other symptoms that may help (I am absolutely stumped here) When the boost and revs get up a bit it backfires, me thinks it's a separate problem, but hell I don't know. I'm thinking about tearing it back apart, and seeing if I can find anything w/ the injectors/gaskets. (You know, I'm REALLY gonna look at that #1 injector. It had elec. tape surrounding the lower O-ring, I wonder if there maybe a vac. leak there????) We shall see.
    Sonic Yellow Snow Cone<br />My WRX pics<br />My Mods

  5. #5

    Hard downshift, rough acceleration

    Hard shifts.. bad tranny vaccuum modulator?
    <br />[size=7pt]2003 Impala LS&nbsp; _&nbsp; Series II 3800 _ Completely stock with 5x,xxx miles[/size]<br />Leather and roof, clean as a whistle.<br />http://gmwbody.com

  6. #6

    Hard downshift, rough acceleration

    There is a vacuum tee right under the turbo for the tranny. Are you sure it isn't leaking there? When we bought the 2 door one of those vacuum hoses was off and the car would jerk violently just as you described, but only on the 2-1 downshift (also as you described). It seemed to shift pretty normal other than that. We drove it around like that for 6 months before finding the problem. I would check that, its always a possibility.

    Shawn
    99 Grand Prix GT 242,800+ miles<br />9.75:1 L36|K&amp;N|No Cat/Ubend/res|160 tstat|UD ALT|Shift Kit|Powertuner|Ported M90/LIM/TB/Heads|XPZ|Stg 2 IC|Pacesetters|ElecWP|AlumCradle|4340 IS|2.93 15/16&quot; Chain|2750 stall|2.55&quot;. <br />379.9whp on 93 octane, 11.9912 @ 112.99 w/1.729 60&#39;<br />Gen V/N* TB/3.69s since ET.<br />03 CBR 600RR Stock.&nbsp; 11.38 @ 123.64

  7. #7

    Join Date
    Aug 2002
    Posts
    651
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Hard downshift, rough acceleration

    Quote Originally Posted by god910
    Hell yes it does, Sunshine gets (yes, I'm talking about average) around 16-17 CITY!!! It gets 23+ highway. I know the extra gear helps, but I ONLY drove on the highway (40 miles a day)
    Actually, the automatic is geared taller than the getrag 282. So you should get better mileage with the automatic on the highway.
    http://www.brian89gp.com/other/transmission.htm


    I would check your vacuum modulator and the checkvalve in front of it, if you haven't already. :P
    <br />&#39;89 Olds Cutlass Ciera International coupe --&gt; L67 - M90 + 60-1 = <br />turbo conversion thread --&gt; http://www.w-body.com/forum/index.php/topic,54582.0.html<br />376whp/371wtq on 14 psi!!!

  8. #8

    Hard downshift, rough acceleration

    So should I just apply vac. and make sure it holds it, and if so the valve is okay. As far as checking the modulator???? I have another one on the auto in the garage (but the valve is missing) It does shift pretty firmly into second (a few more lb/ft, and it might just chirp the tire(s). I looked into the vac. lines to the tranny and everything looks good. I bought a new set of plugs and wires, but the one's on there look great, so I think I'll keep them for another engine. (I only have 4 of them. ) Thanks for your help so far, I'll get to work on this some more this weekend (and get paid for it, GO UAW) and see what comes up. I'm still thinking of taking it to the strip and trying to make a few bucks to fund the research. (And get a few times for Matt's site.)
    Sonic Yellow Snow Cone<br />My WRX pics<br />My Mods

Visitors found this page by searching for:

2002 grand prix hard downshift

tgp downshifts hard

grand prix rough downshift

2002 grand prix no down shift on hard acceleration

grand prix rough acceleration

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •