Page 1 of 2 1 2 LastLast
Results 1 to 15 of 19
  1. #1

    Join Date
    Jan 2004
    Posts
    22
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Erratic Idle, Choppy acceleration, now flickering lights

    Okay, my car has gone goofy in the last 24 hours. I just drove it and the idle is jumping between 500-1500, it idles rough and almost dies when in gear, while in neutral it seems to idle better. While at speed the car surges and feels shaky at 80km/h (50mph) or higher. Then on my way home today the ABS/Brake warning lights came on and the dash lights were flickering like crazy, I turned off the heat and the radio and threw it into neutral and the flickering went away. I just had a new battery installed about a week ago, I am thinking the mechanics didn't tighten the posts properly and maybe this is the source of the problem.

    Could an unstable battery signal cause these problems? all the material on this site seems to suggest that sensors and spark plugs are responsible for the symptoms I have listed an unstable battery signal can cause sensors to fail and improper charge to be delivered to the spark plugs right :?:

    The other thought I had that I am going to check into is maybe the transmisson fluid is low.

    Please let me know if any of you have any thoughts on this

  2. #2

    Join Date
    Oct 2003
    Posts
    308
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Erratic Idle, Choppy acceleration, now flickering lights

    Goodbye Alt. If it's a new battery take it back and demand a charging test
    1992 Chevrolet Lumina Z34 5 Speed - It lives again even if it&#039;s multi-colored... The first Z34 with a UB3<br />1988 Oldsmobile 98 - Try explaining that one to a parts guy<br />1967 Chevrolet C10 Longbox Stepside - Restored <br /><br />&quot;All 3.4 means to the parts guy or mechanic is add another 20% to the bill&quot;

  3. #3

    Join Date
    Jan 2004
    Posts
    22
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Erratic Idle, Choppy acceleration, now flickering lights

    The battery is charging tho and the car is startign no prob, alt is new 1.5 years ago.

  4. #4

    Join Date
    Jan 2003
    Location
    East Grand Forks, MN
    Posts
    5,161
    Thanks
    1
    Thanked 6 Times in 5 Posts

    Erratic Idle, Choppy acceleration, now flickering lights

    Could very well be the terminals aren't tightened properly. Check them and make sure they are. I was thinking an idle relearn should fix it until I read the light problems.. But check the terminals and start from there.
    .. somebody at General Motors must know how to design a turn signal stalk that feels more like a knife in butter than a snapping tree branch.

  5. #5

    Join Date
    Oct 2003
    Posts
    308
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Erratic Idle, Choppy acceleration, now flickering lights

    Ok check connections on the battery. If connections are solid work on back and test the sensors, then go back from there. Any SES Codes or have you seen the Service Engine Soon light come on?
    1992 Chevrolet Lumina Z34 5 Speed - It lives again even if it&#039;s multi-colored... The first Z34 with a UB3<br />1988 Oldsmobile 98 - Try explaining that one to a parts guy<br />1967 Chevrolet C10 Longbox Stepside - Restored <br /><br />&quot;All 3.4 means to the parts guy or mechanic is add another 20% to the bill&quot;

  6. #6

    Join Date
    Jan 2004
    Posts
    22
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Erratic Idle, Choppy acceleration, now flickering lights

    No SES light just the ABS/Brake warning lights, thinking that could be the first system effected in loss of power, that could be the problem.

    Also totally unrelated but when your timing belt on the lumina went what happened immediately before it? any warning signs to look for?

  7. #7

    Join Date
    Oct 2003
    Posts
    308
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Erratic Idle, Choppy acceleration, now flickering lights

    ok if your car whines in idle check your timing belt. I have a feeling thats what the noise was I thought was something else. My Belt snapped at 118,000 km so I say check every 20,000 km. When the belt decides to go the car will have an immeidate power loss if you are driving like I was. Best thing to do is pull over as fast as ya can. The car's noise will change significantly. Vehicle will run like ass if at all.

    What sucks is I was gonna use my tax cheque to replace the belt this spring. It only had to wait 2 more months lol
    1992 Chevrolet Lumina Z34 5 Speed - It lives again even if it&#039;s multi-colored... The first Z34 with a UB3<br />1988 Oldsmobile 98 - Try explaining that one to a parts guy<br />1967 Chevrolet C10 Longbox Stepside - Restored <br /><br />&quot;All 3.4 means to the parts guy or mechanic is add another 20% to the bill&quot;

  8. #8

    Erratic Idle, Choppy acceleration, now flickering lights

    Flickering lights+rough idle=alt eating shit. Sorry, bro. Its on its way.
    your going to find yourselves running...running from those werewolves in space.

  9. #9

    Join Date
    Jan 2004
    Posts
    22
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Erratic Idle, Choppy acceleration, now flickering lights

    I will admit there is the possibility that the alternator is eating it, only the car starts/charges fine, and the only incident of lights flickering was today and only lasted about twenty seconds. I have had alternators die on my RX7 before and this doesn't feel the same at all, I had a loose connection on my old ford crown vic before and it had similar symptoms. I hate electrical problems!! :x

  10. #10

    Join Date
    Jan 2004
    Posts
    22
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Erratic Idle, Choppy acceleration, now flickering lights

    Well I checked the battery terminals and all is well there, I took the car in for an oil change and had the tranny flushed at the same time, no change so I am counting the tranny out of the equation.

    I believe there must be either a vacuum leak, a failing ICM or possibly a bad plug/wire or coil pack. The only other thing I can imagine is maybe the gas station had crappy gas on hand when I filled the car up because in retracing my steps that is the last fluid that went into the car before this all started to happen. I am going to run a fuel treatment through it today and put high octane gas from another station in to see if it helps any. Failiing that I guess I will just have to bite the bullet and do the ICM.

  11. #11

    Join Date
    Jan 2004
    Posts
    22
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Erratic Idle, Choppy acceleration, now flickering lights

    Also the flickering lights and ABS/Brake lights coming on seems to have been an isolated event for that one day it hasn't occurred since so I guess all is well there at least :|

  12. #12

    Join Date
    Aug 2003
    Posts
    957
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Erratic Idle, Choppy acceleration, now flickering lights

    Man, let me know as soon as u fix the problem because i have had almost all of the exact same shit...except my car wants to shut off all the time when i floor it or its under heavy load (75% throttle or more) and i dont think u said anything about that. I tried doing the oxygen sensor, 100 octane gas...map sensor, and replaced a vaccum piece that was still cracked, oh and i changed the speed sensor. So let me know what happens!
    89 TGP Gone....<br />97 GTP Gone....<br />90 TGP is on its way!!! Updates coming soon....

  13. #13

    Join Date
    Sep 2003
    Posts
    318
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Erratic Idle, Choppy acceleration, now flickering lights

    same thing happened to me, it was my lower intake manifold gasket. cracked good on both sides causing a vacuum leak and a mysterious coolant leakage. the leak never hit the ground but the overflow tank would very slowly go down. the idle was fucked, and the ABS light would come on all the time, (only light to come on). i had a pressure test, said had a lower intake manifold leak, had it replaced and it fixed all my problems, nothing wrong ever sense, glad my brother fixed it with me, woulda cost $550

  14. #14

    Join Date
    Jan 2004
    Posts
    22
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Erratic Idle, Choppy acceleration, now flickering lights

    Well, tried the fuel thing, no help there, now my car's exhaust sounds all sputtery and the car shakes at idle I am going to take it to GM tomorrow and get them to diagnose it for me I am tired of pissing money away on things that aren't helping, btw i did notice my coolant was low hrmz... :?

  15. #15

    Join Date
    Jan 2004
    Posts
    22
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Erratic Idle, Choppy acceleration, now flickering lights

    Okay problem solved, a bunch of snow got blown into my intake and into the engine, the snow melted in the upper intake and shorted out two of my plugs so put in 6 brand new plugs and the problem disappears! I'll tell you I couldn't be more relieved that it was only plugs!

Visitors found this page by searching for:

choppy noise when acceleration

my z34 lumina has a fluctuating idle

04 crown victoria dash lights are flickering

my car almost died on my lights were flashing and it was jumpy

rx7 dash lights flashing when accellerating

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •