Page 1 of 2 1 2 LastLast
Results 1 to 15 of 19
  1. #1

    Pulsation/ surge when accelerating

    Took my "new" Regal GS to work the other day and got this pulsation in the engine when I was going up an incline.

    At a little under 65, lightly accelerating to go up, it surged a few times and leveled out on top of hill.

    Now it's starting to do a little on flat ground at light accel.

    Friend who has a Comp G told me plugs. I thought maybe the S/C cuz the coupled needs replaced but throttle wasn't enough to boost.

    Just got it a few days ago. Dealer's service report showed new MAP sensor installed. Nothing else done. Oil wasn't even changed (not that it matters).

    Thoughts??
    1999 Buick Regal GS

    *Gone but not forgotten*
    1992 Olds Cutlass Supreme
    NHRA Oldsmobile Spring Nationals
    Limited Edition

  2. #2
    95 vert's Avatar
    Join Date
    May 2008
    Location
    Kingsville Mo.
    Posts
    852
    Thanks
    15
    Thanked 36 Times in 35 Posts
    EGR? I've had a few 3800 cars do this and the egr valve was weak and opening too much. Unplug and drive and see if the surge goes away. Will cause the check engine lite to come on of course.

  3. #3
    Engine light came on other day and said MAP fail but, it was replaced. Got a new one and didn't change a thing. Found that the air box snorkle wasn't even attached so put my WAI on, calmed it down. Then, replaced the MAP and nothing. Looked at the EGR and the gasket looks new. Read the troubleshooting guide in my Haynes guide and found that I took care of one poss w/ air intake. Also said fuel filter or pump. Pump sounds good, so I'll try the filter.
    1999 Buick Regal GS

    *Gone but not forgotten*
    1992 Olds Cutlass Supreme
    NHRA Oldsmobile Spring Nationals
    Limited Edition

  4. #4

    Join Date
    Jul 2008
    Location
    Pittsburgh, Pa
    Posts
    1,176
    Thanks
    14
    Thanked 14 Times in 11 Posts
    So is it a miss? Whats the tach do when its doing this? Just curious if its a small missfire, or could it maybe be in the transmission?

    VGX Performance Pads & Rotors - K&N Drop In Filter - Muffler Delete W/Flo-Tech Baffled Tips

  5. #5
    It's like I'm revving the throttle to make it continuously jump. Not a missfire. Had that with the Cutty a few weeks ago. Sputttered and chugged horribly due to 2 dying plugs covered in gas and oil.
    1999 Buick Regal GS

    *Gone but not forgotten*
    1992 Olds Cutlass Supreme
    NHRA Oldsmobile Spring Nationals
    Limited Edition

  6. #6

    Join Date
    Apr 2003
    Location
    Cincinnati, OH
    Posts
    17,684
    Thanks
    1,178
    Thanked 428 Times in 258 Posts
    Do a search. Very common issue.

    EDIT: Here you go http://www.w-body.com/showthread.php...ighlight=surge
    Last edited by slick; 01-03-2011 at 01:14 PM. Reason: I wish I were an Oscar Mayer Weiner That is what I truly wish to be cause if i were a oscar mayer weiner everyone would be in
    Chris D.-
    '02 Buick Century- Wife's
    2012 Jeep Grand Cherokee- Company Car/DD

  7. #7
    Big sigh, $10 fixes are so nice. Fuel filter replaced and some Lucas injector cleaner. Ran great this morning. No surge up the hills it did it on. I will keep an eye out on the converter info though. Thanks Chris!
    1999 Buick Regal GS

    *Gone but not forgotten*
    1992 Olds Cutlass Supreme
    NHRA Oldsmobile Spring Nationals
    Limited Edition

  8. #8
    Just to be doing it, maybe also pull the plug wires, one at a time, from the ignition coils to have a look if all the posts look good. Sometimes when those things get corroded, it can cause intermittent misfires until the coil fails completely.
    I had that problem on a 99 lesabre years ago but ignored it until it started running really crappy
    1994 Pontiac Grand Prix GTP. 3.4 DOHC with 197,000 miles, 4 speed automatic.

  9. #9
    That's my next try. It did it some more today. Not as bad though. This time it seemed more missfire.
    1999 Buick Regal GS

    *Gone but not forgotten*
    1992 Olds Cutlass Supreme
    NHRA Oldsmobile Spring Nationals
    Limited Edition

  10. #10
    AL's Avatar
    Join Date
    Apr 2008
    Location
    Toledo, OH
    Posts
    9,208
    Thanks
    22
    Thanked 752 Times in 543 Posts
    442 have your car scanned for KR

  11. #11
    That is what I was thinking. One thing I've been noticing is the SC gauge has been fluxing a lot when it didn't before. Anywhere btwn .5- 2 psi. Usually sits at 0 under idle speeds. Would the fact that a loose coupler be causing this issue?? I took the belt off the other day and noticed a good bit of slack from the pulley. Or could it be the fuel I'm using? Just been using regular b/c prem. is so expensive.
    1999 Buick Regal GS

    *Gone but not forgotten*
    1992 Olds Cutlass Supreme
    NHRA Oldsmobile Spring Nationals
    Limited Edition

  12. #12
    AL's Avatar
    Join Date
    Apr 2008
    Location
    Toledo, OH
    Posts
    9,208
    Thanks
    22
    Thanked 752 Times in 543 Posts
    You need to run premium!

  13. #13
    Sooooooo......... I'm a gonna guess that's my problem Cuz I put a new filter on and put Lucas cleaner in which makes the fuel burn a little higher and cleaner. Hmmmmmmmmm. Soooo, prem. will probably take the rest of the knock out at that point of acceleration. Like I said, first supercharged car.
    1999 Buick Regal GS

    *Gone but not forgotten*
    1992 Olds Cutlass Supreme
    NHRA Oldsmobile Spring Nationals
    Limited Edition

  14. #14
    AL's Avatar
    Join Date
    Apr 2008
    Location
    Toledo, OH
    Posts
    9,208
    Thanks
    22
    Thanked 752 Times in 543 Posts
    Most likely... Until you put premium in... Try to stay out of boost

  15. #15
    BXX's Avatar
    Join Date
    Aug 2006
    Location
    Lorain, Ohio
    Posts
    8,256
    Thanks
    14
    Thanked 373 Times in 309 Posts
    Indeed cause if your knock sensor decides its overworked, youll have a piston in peices.

    Hypereutectic (sp?) pistons HATE boost.
    -08 Kia Spectra SX -2.0L BetaII/Auto
    -02 Buick Rendezvous CXL -3.5L LX9 Swap/4t65e

Visitors found this page by searching for:

car surging when accelerating

car surging while accelerating

car surging on acceleration

car surges while accelerating

car surges under acceleration

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •