Page 3 of 3 FirstFirst 1 2 3
Results 31 to 41 of 41
  1. #31
    cutlasssupremeking's Avatar
    Join Date
    Sep 2009
    Location
    Irvine, CA
    Posts
    35
    Thanks
    0
    Thanked 0 Times in 0 Posts

    ECM/PCM (computer) not giving code 12. Just blink, long pause, blink, long pause

    I just replaced my ECM in effort to get my car running again along with a myriad of other things. I am concerned about this Check Engine Light sequence I am getting. Its blink, long pause, blink, long pause. And it repeats. The thing is, that I get this sequence all the time, even if I am not checking for Trouble Codes!
    What is going on? Is my ECM dead?


    Here is the link to my previous thread for my car troubles, I don't know that it will help much:
    http://www.w-body.com/forum/index.php?topic=83202.0

  2. #32
    ManicMechanic's Avatar
    Join Date
    Dec 2004
    Location
    FEMA Region 6
    Posts
    8,451
    Thanks
    322
    Thanked 503 Times in 391 Posts

    Re: ECM/PCM (computer) not giving code 12. Just blink, long pause, blink, long pause

    Sounds like wrong ECM.
    Jay
    "Eh, ya know somethin' Jimmy...It's one thing to understand how to bolt aftermarket parts to your car...It's another thing entirely (opens exhaust on GN) to understand how they all..work..together!"

    I may not have a W anymore, but my trucks have a lot of w-body parts.
    THE ANSWER TO 1984 IS 1776.

  3. #33
    cutlasssupremeking's Avatar
    Join Date
    Sep 2009
    Location
    Irvine, CA
    Posts
    35
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: ECM/PCM (computer) not giving code 12. Just blink, long pause, blink, long pause

    You mean that Kragen gave me the wrong part for my car?!

  4. #34
    ManicMechanic's Avatar
    Join Date
    Dec 2004
    Location
    FEMA Region 6
    Posts
    8,451
    Thanks
    322
    Thanked 503 Times in 391 Posts

    Re: ECM/PCM (computer) not giving code 12. Just blink, long pause, blink, long pause

    Entirely possible.
    Jay
    "Eh, ya know somethin' Jimmy...It's one thing to understand how to bolt aftermarket parts to your car...It's another thing entirely (opens exhaust on GN) to understand how they all..work..together!"

    I may not have a W anymore, but my trucks have a lot of w-body parts.
    THE ANSWER TO 1984 IS 1776.

  5. #35
    BXX's Avatar
    Join Date
    Aug 2006
    Location
    Lorain, Ohio
    Posts
    8,256
    Thanks
    14
    Thanked 373 Times in 309 Posts

    Re: ECM/PCM (computer) not giving code 12. Just blink, long pause, blink, long pause

    Yup. I would say its the wrong PCM, or the wrong memcal unit in it.
    -08 Kia Spectra SX -2.0L BetaII/Auto
    -02 Buick Rendezvous CXL -3.5L LX9 Swap/4t65e

  6. #36
    Mach 5's Avatar
    Join Date
    Jun 2006
    Location
    West Islip, NY
    Posts
    1,473
    Thanks
    34
    Thanked 34 Times in 28 Posts

    Re: Codes 22, 33, 35, 44, 45. What does this mean? What do I do?

    Did you check the wiring for the map tps and the iac? Sounds like you got a break somewhere. I believe they all use the same basic circuit. the o2 codes are probably being caused being this. Check for 5v reference at all 3 sensors, your ground, and the signal wires.
    Founder of the Radical Revs Racing Team- Radical Revs Race Mods
    -Jarek-
    Mach 5-1989 Pontiac Grand Prix SE- untuned basemap 16psi 336hp 442tq, LG5 swap, GT3076r, Getrag 282, Birchmount
    Racer X- 1990 McLaren TGP- GTX3582r high boost- Getrag 284- Tilton Twin disc- LG5 w/ 34xx race heads, race cam, custom intake, build in progress
    1985 AE86- 4age 20v, supra trans, 4.78:1 final 173hp
    1987 Mitsubishi Starion- 2.6l turbo 5spd build in progress
    1991 Toyota Extended Pickup- WONTONPU- LCE Headers, RRRM Exhaust, 121hp 150tq

  7. #37
    Hairdo12's Avatar
    Join Date
    Dec 2002
    Location
    Buffalo NY
    Posts
    684
    Thanks
    3
    Thanked 20 Times in 18 Posts

    Re: ECM/PCM (computer) not giving code 12. Just blink, long pause, blink, long pause

    I would check to make sure there is a memcal in that ecm. You may need to remove the memcal from your old ecm and put it in the new one because I think new ecm's don't come with the memcal. If your old memcal is suspect... try a junk yard for the same year/motor/model.

    2006 Impala SS LS4 V8
    1992 Lumina 04/2000 - 10/2010

  8. #38
    RobertISaar's Avatar
    Join Date
    Sep 2006
    Location
    Camden, MI
    Posts
    9,606
    Thanks
    1,267
    Thanked 2,498 Times in 1,861 Posts

    Re: ECM/PCM (computer) not giving code 12. Just blink, long pause, blink, long pause

    if you post the BCC i can tell you what all MEMCALs will work...
    Baron of 6811
    1995 Monte Carlo LS 3100, 4T60E... for now, future plans include driving it until the wheels fall off!



  9. #39
    Forum Moderator mfewtrail's Avatar
    Join Date
    Nov 2002
    Location
    GA
    Posts
    6,511
    Thanks
    10
    Thanked 158 Times in 122 Posts

    Re: ECM/PCM (computer) not giving code 12. Just blink, long pause, blink, long pause

    I merged this thread with your old one since this is just a continuation of the same problem. From now on, do not start a separate topic for the same problem. Posting in your old thread brings it to the top where everyone will see it. By the way, you can edit the first post in a thread to change the title of it to reflect an update/or new issue you want to put emphasis on.

  10. #40
    cutlasssupremeking's Avatar
    Join Date
    Sep 2009
    Location
    Irvine, CA
    Posts
    35
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: ECM/PCM (computer) not giving code 12. Just blink, long pause, blink, long pause

    Oooh, okay. That's a handy trick. Thanks. I won't dual post for the same problem.

  11. #41
    cutlasssupremeking's Avatar
    Join Date
    Sep 2009
    Location
    Irvine, CA
    Posts
    35
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: What do these Trouble Codes mean?! 22, 33, 35, 44, 45.

    The Memcal is fine. I think I made the mistake of leaving the battery connected when I plugged in the new ECM/PCM. That probably fried it. I got another ECM and unplugged the battery this time and the car started right up. I think it was the last of a number of needed fixes.
    But, my car liiiiiives! Thanks guys for all your help and suggestions.

    Oh, and I think the 'blink, long pause, blink, long pause' means that the computer is not working, get a dang new one. I don't think 'blink, long pause, blink, long pause' isn't a Trouble Code. I think its a 'you messed up big genius!' code.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •