Results 1 to 9 of 9
  1. #1

    Turn Signal Troubles

    No big deal, but sometimes when I go to make a left turn, the turn signal won't come on. The indicators doesn't light up and the lights don't flash. I have to whack the stalk up and down a few times to make it work.

    Is there some sort of contact that's not working...or is this an indicator of something more? The bulbs all work. I haven't tried it, but I've been thinking of squirting some compressed air where the stalk meets the wheel.

    This is a 95 Buick Regal, 3.1, with the coolant ever-leak option and the bird-crap attracting paint job.
    1995 Buick Regal 3.1 <br />_________________<br /><br />Reality is just something you must rise above.

  2. #2
    mediabandit's Avatar
    Join Date
    Oct 2006
    Location
    Halifax, Nova Scotia, Canada
    Posts
    1,636
    Thanks
    22
    Thanked 20 Times in 17 Posts

    Re: Turn Signal Troubles

    http://tss.likeabigdog.com

    Common occurence in these cars.

    Epic Miami 896 Rims / Dual Free Flow Exhaust
    HID Conversion / WO-Tech Chip
    MMI FWI / Aweb RSTB
    Vert FSTB

  3. #3
    Breakdown's Avatar
    Join Date
    Sep 2007
    Location
    Kitchener, ON
    Posts
    3,296
    Thanks
    236
    Thanked 797 Times in 530 Posts

    Re: Turn Signal Troubles

    Quote Originally Posted by Ned Flanders
    No big deal, but sometimes when I go to make a left turn, the turn signal won't come on. The indicators doesn't light up and the lights don't flash. I have to whack the stalk up and down a few times to make it work.

    Is there some sort of contact that's not working...or is this an indicator of something more? The bulbs all work. I haven't tried it, but I've been thinking of squirting some compressed air where the stalk meets the wheel.

    This is a 95 Buick Regal, 3.1, with the coolant ever-leak option and the bird-crap attracting paint job.
    MediaBandit is dead on.

    In the meantime you can force the turning stalk down a little more than normal to ensure that you're signalling your turns, but eventually that will fail and you won't be able to signal the left turns at all.

    You may already have or be in the process of losing your left brake light as well.

    Here, these are $250-300 Cdn to do (labour in), so in the States I would say $175-250 at a shop, probably a small premium if you go to Generous Motors and ask them to hook you up.


    BREAKDOWN ABILITIES: In car mode, his engine emits vibration that causes mechanical failures in other vehicles...can speed to 200 mph...uses concussion cannon in robot mode.
    Quote Originally Posted by bigalwalker08
    Ignore 90% of the comments here but be sure to listen to Breakdown.
    Quote Originally Posted by xtremerevolution
    If it took me 7-14 hours to change an alternator, I'd set the car on fire and roll it down a hill.
    . . .then I'd set myself on fire.

  4. #4

    Re: Turn Signal Troubles

    Since it's not doing it all the time (yet) I'm going to wait awhile.
    1995 Buick Regal 3.1 <br />_________________<br /><br />Reality is just something you must rise above.

  5. #5
    1990lumina's Avatar
    Join Date
    Sep 2004
    Location
    Saskatoon, SK, Canada
    Posts
    6,171
    Thanks
    1
    Thanked 10 Times in 4 Posts

    Re: Turn Signal Troubles

    Do your brake lights still work? EVERY 1.5 Lumina Isee now has no signal lights and no brake lights.
    Jeff L. :: 2nd Canadian to win COTM The Preservation for POS W-bodies Canada Chapter
    2004 Acura TSX | 2.4L I4 iVTEC; 5 Speed Auto | 1 of Many Made In '04 | 89,XXXKM
    1990 Chevrolet Lumina Euro 3.1 | 3.1L 191ci 60 V6; 440T4 | 1 of 43,912 Made In '90 | 194,XXXKM
    1985 Mazda RX-7 S | 1.1L 70ci 12A Twin Rotor RE; 5spd | 1 of 63,105 Made in '85 | 130,XXXKM

  6. #6
    Breakdown's Avatar
    Join Date
    Sep 2007
    Location
    Kitchener, ON
    Posts
    3,296
    Thanks
    236
    Thanked 797 Times in 530 Posts

    Re: Turn Signal Troubles

    Quote Originally Posted by 1990lumina
    Do your brake lights still work? EVERY 1.5 Lumina Isee now has no signal lights and no brake lights.
    I've found it's usually only on the side of the affected signal.


    BREAKDOWN ABILITIES: In car mode, his engine emits vibration that causes mechanical failures in other vehicles...can speed to 200 mph...uses concussion cannon in robot mode.
    Quote Originally Posted by bigalwalker08
    Ignore 90% of the comments here but be sure to listen to Breakdown.
    Quote Originally Posted by xtremerevolution
    If it took me 7-14 hours to change an alternator, I'd set the car on fire and roll it down a hill.
    . . .then I'd set myself on fire.

  7. #7
    1990lumina's Avatar
    Join Date
    Sep 2004
    Location
    Saskatoon, SK, Canada
    Posts
    6,171
    Thanks
    1
    Thanked 10 Times in 4 Posts

    Re: Turn Signal Troubles

    The car's I see don't have either signal light either
    Jeff L. :: 2nd Canadian to win COTM The Preservation for POS W-bodies Canada Chapter
    2004 Acura TSX | 2.4L I4 iVTEC; 5 Speed Auto | 1 of Many Made In '04 | 89,XXXKM
    1990 Chevrolet Lumina Euro 3.1 | 3.1L 191ci 60 V6; 440T4 | 1 of 43,912 Made In '90 | 194,XXXKM
    1985 Mazda RX-7 S | 1.1L 70ci 12A Twin Rotor RE; 5spd | 1 of 63,105 Made in '85 | 130,XXXKM

  8. #8
    Lurker
    Join Date
    Nov 2005
    Posts
    648
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Turn Signal Troubles

    Alright, a HUGE bump for this topic, but only because it is the exact same issue I am having and all of the information is already here in this thread.

    My question is, my turn signal has been doing this for some time and when it gets super cold it stops working completely. Yet if I pull back on it a bit as if I'm using my brights, it comes on. My right blinker still blinks but the left one will only come on solid.

    I have NOT noticed any kind of brake light issue however, do they always happen together? Maybe my brake lights are acting up but I don't know it?!?
    http://www.spudfiles.com
    Blast vegetables and whatever else you can think of! :laugh:

    1996 3500GP Coupe, "Bright White"
    3500 swap, 60degreeV6 1393 Grind Cam, Ported Intakes, Comp Cams Valve Springs, 65mm TB, Custom Pushrods, S&S Headers, 97 PCM with DHP Powrtuner, 2.5"; back to dual Hooker Aerochambers, SS Brake Lines, Addco Swaybar, KYB's, Intrax Springs, STB's, etc!

  9. #9

    Join Date
    May 2007
    Posts
    7,252
    Thanks
    597
    Thanked 287 Times in 206 Posts

    Re: Turn Signal Troubles

    Quote Originally Posted by PCGUY112887
    Alright, a HUGE bump for this topic, but only because it is the exact same issue I am having and all of the information is already here in this thread.

    My question is, my turn signal has been doing this for some time and when it gets super cold it stops working completely. Yet if I pull back on it a bit as if I'm using my brights, it comes on. My right blinker still blinks but the left one will only come on solid.

    I have NOT noticed any kind of brake light issue however, do they always happen together? Maybe my brake lights are acting up but I don't know it?!?
    That's definitely your turn signal switch. 100% sure.

Visitors found this page by searching for:

95 regal blinker wont blink

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •