Results 1 to 6 of 6
  1. #1

    Join Date
    Feb 2006
    Posts
    13
    Thanks
    0
    Thanked 0 Times in 0 Posts

    2000 Lumina Flashing Low Coolant Light

    Hello!

    I recently changed out my waterpump. No big deal at all, and I still have a slight leak around the seal I think, but nothing to worry about. I've lost the coolant a couple of times but now its either stopped, or has become a very slow leak.

    However, I recently noticed a flashing low coolant light that is invalid since the
    bottle and radiator are full.

    What might cause this, and where is the sensor for the coolant level located?

    Thanks!

  2. #2
    terryk2003's Avatar
    Join Date
    Sep 2004
    Location
    Oberlin, Ohio
    Posts
    4,136
    Thanks
    92
    Thanked 28 Times in 18 Posts

    Re: 2000 Lumina Flashing Low Coolant Light

    did you bleed the air out of your cooling system?...if not, you probably have air bubbles in there that are setting your low collant light off...
    -Terry K.

    '03 Grand Prix GTP -
    A Couple Mods - 240WHP 333WTQ
    '05 Cobalt-
    5 Speed - Daily Driver/Beater

  3. #3
    19Cutlass94's Avatar
    Join Date
    Apr 2005
    Location
    Texas
    Posts
    10,445
    Thanks
    49
    Thanked 546 Times in 325 Posts

    Re: 2000 Lumina Flashing Low Coolant Light

    Quote Originally Posted by terryk2003
    did you bleed the air out of your cooling system?...if not, you probably have air bubbles in there that are setting your low collant light off...
    Thats what I was thinking when I was reading it.
    Jay

    1994 Oldsmobile Cultass Supreme SL
    3400/Getrag 284 5spd
    1995 Chevy K1500 350c.i. 5spd Z71
    350/NV3500 5spd

  4. #4
    Forum Moderator digitaloutsider's Avatar
    Join Date
    May 2003
    Location
    Pittsburgh, PA
    Posts
    7,335
    Thanks
    55
    Thanked 199 Times in 100 Posts

    Re: 2000 Lumina Flashing Low Coolant Light

    Or the sensor is bad. I can't count how many 97-03 GP's I've seen with this problem.


    2006 Nissan Altima SE-R 3.5L 214ci VQ35DE DOHC 60 V6 | 6MT
    Raclingline HFPCs and Y-pipe, NWP VIAS delete, Goodridge SS brake lines, removed airbox snorkel, deburgered.

    1998 Jeep Grand Cherokee 5.9 Limited 5.9L 360ci Magnum Pushrod 90 V8 | 46RE | NV249
    Flowmaster 50 SUV muffler, 180 t-stat, CAI.

    1990 Pontiac Turbo Grand Prix 3.1L 191ci Turbocharged 60 V6 | 4T60-HD
    Perpetually broken.

  5. #5

    Join Date
    Jul 2011
    Posts
    75
    Thanks
    2
    Thanked 0 Times in 0 Posts
    I am having this problem now! My 97 chevy lumina has its "low coolant" lamp flicking on and off, it never stays one. it just blips and disappears. Sometimes for 1 second sometimes for 10 seconds. My car does not over heat, my fans turn on , I check i have good levels of coolant. COuld it be a bad coolant sensor? I will try and smack it with a hammer tonight

  6. #6
    19Cutlass94's Avatar
    Join Date
    Apr 2005
    Location
    Texas
    Posts
    10,445
    Thanks
    49
    Thanked 546 Times in 325 Posts
    Jay

    1994 Oldsmobile Cultass Supreme SL
    3400/Getrag 284 5spd
    1995 Chevy K1500 350c.i. 5spd Z71
    350/NV3500 5spd

Visitors found this page by searching for:

low coolant light flashing chevrolet lumina

chevy lumina low coolant light flashing

lumina low coolant light

lumina low coolant light flashes

2000 chevy lumina low coolant light

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •