Results 1 to 12 of 12
  1. #1

    1990 Cutlass Supreme Possessed???

    Okay we inherited a 1990 Olds Cutlass Supreme SL 3.1L V6 71K a month or so ago. It had been stored for a few years but thought I would get it running since it would get better gas mileage than my trucks. Said to run perfect before storage.

    New battery and a change of fuel and fuel filter plus a oil change. It fired right up and drove fine for a day or so.
    Now while driving the Instrument cluster-odometer/spedo will reset to zero. When this happens the engine will surge and a dash light illuminates for a brief second and the A/C will stop working. The same thing happens when it starts to work and continues operating normally (surge in power and flicker of dash lights). It is also getting extreme engine idle responses. One minute the engine will sputter/spit/stall when coming to a stop sign/light. Then the next minute it idles extremely high. I am also getting fluctuating fuel mileage.
    Not sure what the heck is going on…

    I cleaned the Idle air control valve and throttle body, ran some gas treatment through. Cannot find the PCV valve nor sure how to even change the plugs/wires in the transverse engine with noo room..

    Any Ideas?

    Regards,
    Sean

  2. #2
    1990lumina's Avatar
    Join Date
    Sep 2004
    Location
    Saskatoon, SK, Canada
    Posts
    6,171
    Thanks
    1
    Thanked 10 Times in 4 Posts

    1990 Cutlass Supreme Possessed???

    For your idle you could try an idle relearn. You should probably do this anyway since the ecm lost power when you changed the battery. I'd also check the alternator output as if you aren't getting at least 12 volts from the system you will run into electricial problems such as you intument cluster going nuts.
    You are getting bad mileage because of the erratic idle I'm guessing.

    - Jeff L.
    Jeff L. :: 2nd Canadian to win COTM The Preservation for POS W-bodies Canada Chapter
    2004 Acura TSX | 2.4L I4 iVTEC; 5 Speed Auto | 1 of Many Made In '04 | 89,XXXKM
    1990 Chevrolet Lumina Euro 3.1 | 3.1L 191ci 60 V6; 440T4 | 1 of 43,912 Made In '90 | 194,XXXKM
    1985 Mazda RX-7 S | 1.1L 70ci 12A Twin Rotor RE; 5spd | 1 of 63,105 Made in '85 | 130,XXXKM

  3. #3

    1990 Cutlass Supreme Possessed???

    Check your electrical grounds.

  4. #4
    Anonymous
    Guest

    1990 Cutlass Supreme Possessed???

    yes, sounds like an electrical problem as far as the cluster goes.

  5. #5

    1990 Cutlass Supreme Possessed???

    Off the top of my head it seems like a bad ECM. If you could grab one cheap off ebay or a Junkyard, swap it, do a proper idle relearn and see what happens.
    Yeah, it's still on the road. 219,982 mi


  6. #6

    Join Date
    Mar 2004
    Posts
    356
    Thanks
    0
    Thanked 0 Times in 0 Posts

    1990 Cutlass Supreme Possessed???

    The plugs are not hard to change They're in holes in the heads that are plugged up by spark plug wires. I need about a foot in extensoins to get to the plugs though. :x
    1992 Lumina Z34 Metallic Grey Auto
    <br />2-2
    <br />
    <br />The more I think about it, the bigger dumbass I am.
    <br />A Motion Phase III Camaro could brain-smash a winged-up, fart-can-fitted front-wheel-drive latter-day pretender from the land of the rising sun until its "bling" ran red in the streets

  7. #7

    Join Date
    Aug 2002
    Location
    Battlefield, MO
    Posts
    10,772
    Thanks
    160
    Thanked 425 Times in 302 Posts

    1990 Cutlass Supreme Possessed???

    How are the volts? My guess would be bad alternator.

  8. #8

    Join Date
    Sep 2004
    Posts
    349
    Thanks
    0
    Thanked 0 Times in 0 Posts

    1990 Cutlass Supreme Possessed???

    Reseting Cluster, Engine Surging, and flickering of dash lights sounds like a shady ground somewhere.

    The idle fluctuations sounds like a bad intake manifold gasket or IAC.

    However a bad ECM would cause all of the above symptoms too, but I'd try to rule other things out first.
    -Jon-
    <br />1995 Chevrolet Impala SS - Sickly Stock
    <br />2000 Chrysler Concorde 3.2 Auto, Pimp, 19 inch rims, lowered 2 inches, pearlized white paint, and 1400watt stereo.
    <br />

  9. #9

    Join Date
    Dec 2004
    Posts
    137
    Thanks
    0
    Thanked 0 Times in 0 Posts

    1990 Cutlass Supreme Possessed???

    Well first off i would check the alt... Mine was doing the same thing as mine... It was the alt over charging the battery. One of the regulators went bad in it.. take it to autozone or some other parts store by you its free to get it checked... You cant beat that with a stick.
    quote i took from DanTGP.&nbsp; &nbsp; My ABS light comes on and the speedo and tach needles go from Michael J. Fox shakey to Katherine Hepburne seizure.

  10. #10

    Join Date
    Mar 2005
    Posts
    90
    Thanks
    0
    Thanked 0 Times in 0 Posts

    1990 Cutlass Supreme Possessed???

    I would recheck the battery cables for corrosion and tightness, next would be making sure the ground from the battery to block is in good condition. Sounds to me like you have a bad ground or connection somewhere. The erratic idle problem is probably just the idle needing to be relearned.

  11. #11

    1990 Cutlass Supreme Possessed???

    Okay I replaced the PCM/ECM and most things are back to “normal”.

    I had found a cheap one at a salvage yard out of a 92 Cutlass 3.1L car ran awesome buttttt the relays for the AC/Cooling fans would not work with it. So I purchased a new one (rebuild) and put my old prom chip in and the car started acting up again. Dropped the 92 PROM in and everything is back to working correctly with exception of AC and the Speedo works but seems to be off. So the culprit seems to have been my old PROM chip? I am guessing the speedo problem is because the 92 CS had a 4sp Auto and my 90 has a 3sp Auto???

    Anyone know where to purchase PROM chips cheap? Don’t need a High Performance one.

    Thanks,
    Sean

  12. #12

    Join Date
    Jun 2004
    Posts
    507
    Thanks
    0
    Thanked 0 Times in 0 Posts

    1990 Cutlass Supreme Possessed???

    The dealer, I think price isnt too bad either, they can do it with your vin #
    &#039;89 Cutlass Supreme 3.1 2dr,&nbsp; &#039;90 GMC 4X4<br />&#039;84 K5 BLAZER 4X4,&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &#039;86 Vette<br />&#039;97 Saturn 5spd<br />

Visitors found this page by searching for:

fuel filter 1990 oldsmobile cutlass supreme

1990 cutlass supreme troubleshooting

1990 oldsmobile cutlass supreme problems

fuel pump relay 1990 olds cutlass 3.1 diagram

1990 oldsmobile cutlass surging

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •